How to configure Mikrotik/SmartCache VideoCacheBox Checker.

1 - Define the comment of your Mikrotik Route:
In Routes definition, edit the route for the SmartCache VideoCacheBox and comment "vcbox" (without quotes)
2 - Define the special Mangle for enabling/disabling:
Original code
/ip firewall mangle
add action=add-dst-to-address-list address-list=MONVCB address-list-timeout=20s chain=prerouting\
comment="VCB Hello Packet" dst-port=2048 protocol=udp src-address=[vcb-ip]
  • address-list: Addr. list name of your IP ranges
  • address-list-timeout: timeout when the Mikrotik will ON/OFF the rule
  • src-address: IP address of the SmartCache VideoCacheBox
3 - Define the special Scheduler for enabling/disabling:
Original code
/system scheduler
add interval=10s name="MONITORING VCB" on-event=":global VCB\r\n\
:if ([/ip firewall address-list find list=MONVCB] = \"\") do={\r\n\
:if (\$VCB != \"down\") do={\r\n\
/ip route disable [find comment=\"vcbox\"]\r\n\
:set VCB \"down\"\r\n\
:log info \"VCB DOWN\"\r\n\
}\r\n\
} else={\r\n\
:if (\$VCB != \"hidup\") do={\r\n\
/ip route enable [find comment=\"vcbox\"]\r\n\
:set VCB \"hidup\"\r\n\
:log info \"VCB UP\"\r\n\
}\r\n\
}" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive
4 - Enable Mikrotik Checker from SmartCache VideoCacheBox web console.
Thanks to Mohammad Charkhandaz for his participation in writing the FAQ